こんにちは!くまかけです。
rbenv+ruby-build環境を利用してRuby2.2.1をインストールしました。
rbenv+ruby-build環境の構築はこちらを参考ください。

■Rubyのバージョンを確認します。

# rbenv install -l
:
2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5
2.2.0-dev
2.2.0-preview1
2.2.0-preview2
2.2.0-rc1
2.2.0
2.2.1
2.3.0-dev
:

■Rubyをインストールします。

# rbenv install 2.2.1

libffi.aが無いって感じですね。。。

# yum install libffi-devel

# rbenv install 2.2.1
# rbenv global 2.2.1
# ruby -v
ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-linux]

■参考資料

Rubyをrbenv+ruby-buildを利用してインストールする手順 (CentOS/RedHat)